Notifications
Clear all

[Solved] Installation

   RSS

0
Topic starter

Hi,

I am facing an issue while installing beedms 2.0.0

1. Do beedms 2.0.0 support on linux OS ?
2. When i access page using url whole index.php getting download as it without executing
i found it is because

AddHandler application/x-httpd-php7  .php7 .php


line in .htaccess when remove it, it works

3. here installation step mentions about free_dms.sql  i didn't found that sql file
https://beedms.com/db-installation/

4. here installation document mentioned to run command to install sql 

php artisan migrate
php artisan db:seed

but i am getting error while executing command 

Class 'RachidLaasri\LaravelInstaller\Providers\LaravelInstallerServiceProv
ider' not found

https://beedms.com/installation-on-local-machine/

5. i am getting this error even after filling database detail in .env file

SQLSTATE[HY000] [1045] Access denied for user 'root'@'localhost' (using password: NO) (SQL: select * from `master_settings` where `key_name` = _COMPANY_LOGO_ limit 1)

i found bootstrap/cache/config.php have hard coded sql detail in it i deleted config.php and service.php then its worked

 

6. then i got this error

file_put_contents(C:\xampp0\htdocs\dms\storage\framework/sessions/0nlav6z0uS6JiKUCGNQso6DsrL6PyY3MvNTgCljW): failed to open stream: No such file or directory

strange i use linux but this path seems like windows path C:\xampp0\htdocs\dms
that you forget to delete cache before deploying beedms package to use

i deleted dms/storage/framework/cache/data then it worked

6. Then i got this error

Parse error: syntax error, unexpected ':', expecting '{' in /home/soft/public_html/manual/beedms/vendor/werneckbh/qr-code/src/helpers/functions.php on line 10

i found one of your dependency using "Type declarations for parameters and return values" which is introduced in php 7.1 but your application supports 5.6 as mentioned here https://beedms.com/installation-on-local-machine/

i moved on php 7.1 then i am getting this error

Class 'RachidLaasri\LaravelInstaller\Providers\LaravelInstallerServiceProvider' not found

what to do?

@kanduganesh
Sorry to see you face such problems as we are updating it to next release. You can have quick demo from http://v2.beedms.com for time being. One of our support team will reply you in details on how to solve above.

@kanduganesh
Hello Sir, I might help you with all the errors. Please find my answers below in the order of your questions.
1. Yes, beedms 2.0.0 supports on Linux. It has been developed in PHP in Laravel Framework.

2. This problem could be showing because of wrong PHP version. Please use PHP version 7.1 using php version manager in your cpanel.

3. You can download sample SQL from here. It also includes all details that will help you learn on how you can import it.

4. If you have good knowledge of Laravel you can use artisan commands or you can just import the SQL. For the problem Class 'RachidLaasri\LaravelInstaller\Providers\LaravelInstallerServiceProvider' not found you can go config/app and remove the line from there.

5. This error is with the access of the SQL, you can change in the .env file or you can just write command php artisan config:clear

6. Ok, I think this is because of cache. You can use command like php artisan config:clear or cache:clear. Or you can just URL /clear-cache. Use one of any means to clear the cache please.

7. 7.1 would be better option, about that Class 'RachidLaasri\LaravelInstaller\Providers\LaravelInstallerServiceProvider' not found error please go to config folder and then to app.php. There you can remove this line of code.
I guess this will solve your error. If you have more inquiry please let us know

We are going to release updated script by the end of this week which will have all these issues pre-solved. Sorry for inconvenience. Should you have any questions, please do not hesitate to contact us.

Topic Tags
5 Answers
1

@kanduganesh
Hello Sir, I might help you with all the errors. Please find my answers below in the order of your questions.
1. Yes, beedms 2.0.0 supports on Linux. It has been developed in PHP in Laravel Framework.

2. This problem could be showing because of wrong PHP version. Please use PHP version 7.1 using php version manager in your cpanel.

3. You can download sample SQL from here. It also includes all details that will help you learn on how you can import it.

4. If you have good knowledge of Laravel you can use artisan commands or you can just import the SQL. For the problem Class 'RachidLaasri\LaravelInstaller\Providers\LaravelInstallerServiceProvider' not found you can go config/app and remove the line from there.

5. This error is with the access of the SQL, you can change in the .env file or you can just write command php artisan config:clear

6. Ok, I think this is because of cache. You can use command like php artisan config:clear or cache:clear. Or you can just URL /clear-cache. Use one of any means to clear the cache please.

7. 7.1 would be better option, about that Class 'RachidLaasri\LaravelInstaller\Providers\LaravelInstallerServiceProvider' not found error please go to config folder and then to app.php. There you can remove this line of code.
I guess this will solve your error. If you have more inquiry please let us know

We are going to release updated script by the end of this week which will have all these issues pre-solved. Sorry for inconvenience. Should you have any questions, please do not hesitate to contact us.

0

Ich bin gegen covid 19. Was ist deine Meinung? mituns

0

HI Guys. Thanks for my approving / wazz user, new user hehe

0

Where is a my topic with invite? Hmm i cant find it now ;/ wizz

0

yyy where can i find a shoutbox message? / sells

Share:
Back to Top